WhatsApp Ends Support for Android Eclair and Froyo

WhatsApp for Android

WhatsApp has announced that effective in 2017, support for several legacy mobile OS versions has been or will be eliminated.  For Android, Eclair (version 2.1) and Froyo (version 2.2) are on the list.  What this means is if you are running a device with Android 2.1 or 2.2 (which begs the question, why?) you will no longer get support from WhatsApp for any issues.  That doesn’t necessarily mean that the app on your phone will quit working, just that future updates may not be available (highly likely).

Android wasn’t the only OS impacted.  Support for BlackBerry OS and Blackberry 10 was dropped as well as Nokia Symbian S60 and Windows Phone 7.  Here is the complete list:

  • BlackBerry OS and BlackBerry 10
  • Nokia S40
  • Nokia Symbian S60
  • Android 2.1 and Android 2.2
  • Windows Phone 7
  • iPhone 3GS/iOS 6

As you can see, all of these are rather old mobile OS builds.

Continue reading “WhatsApp Ends Support for Android Eclair and Froyo”